Leave a comment

Eliminazione disturbi video su uno ZX Spectrum collegato ai Microdrive

Qualche tempo fa abbiamo pubblicato un articolo sulla riparazione di uno ZX Spectrum donato all’associazione. Quello che segue è un aggiornamento sugli interventi resisi necessari per completare la riparazione a seguito di ulteriori problemi emersi in fase di test più approfonditi.

AGGIORNAMENTO Agosto 2018

Durante il test finalizzato a valutare l’idoneità del computer ad effettuare una dimostrazione nel corso di un evento pubblico dell’associazione in programma qualche giorno dopo, lo Spectrum viene collegato ad una ZX Interface 1 per testare il funzionamento con un ZX Microdrive. In quell’occasione vengono riscontrate notevoli interferenze sul segnale video.

Le interferenze si accentuano quando il motore del microdrive è in azione. A video compaiono delle fasce di colore giallo.

Resosi dunque necessario un ulteriore intervento, analizzo le tensioni e scopro che mancano i -5v ed i +12v. Il computer, nonostante ciò, funziona giacchè monta un modulo sostitutivo della RAM alta, il quale necessita solo dei +5v per funzionare. Studiando il circuito di alimentazione scopro un condensatore capovolto, un diodo aperto e lo ztx650 aperto, alcuni condensatori elettrolitici sospetti di cui uno, in particolare, sulla linea dei -5v che pilota il transitor bruciato c43 da 100nf. Quest’ultimo risulta fuori tolleranza di parecchio, quanto basta da causare il malfunzionamento.

Effettuate le sostituzioni dei componenti ritenuti guasti, i difetti video scompaiono tutti ad eccezione delle strisce gialle. La sollecitazione dei trimmer che regolano la saturazione del colore (presenti sulle Issue 2) determina una momentanea scomparsa delle suddette strisce. Decido per la sostituzione dei trimmer ed anche l’ultimo difetto scompare.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

x Shield Logo
This Site Is Protected By
The Shield →